
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.jsuchanticleer.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="" />
<meta name="news_keywords" content="" />
<meta name="description" content="Wednesday&rsquo;s occurrence involving JSU student Leah Tarvin being struck by a motor vehicle has pained the Jacksonville community." />
<meta name="author" content="the editorial staff of The Chanticleer" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?crop=1920%2C1008%2C0%2C35&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Editorial: ALDOT should act now to save lives" />
<meta property="og:description" content="Wednesday&rsquo;s occurrence involving JSU student Leah Tarvin being struck by a motor vehicle has pained the Jacksonville community." />
<meta property="og:site_name" content="The Chanticleer" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.1c52af6b9bc35f467ffe99508ecf766a.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.6ee2c17f3ef34e32b5fa02524f5978e7.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Fira+Sans:wght@300;400;500;600;700;900&amp;family=DM+Serif+Text&amp;display=swap"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.a27bf5e332f0dd667184ad38b7bf1638.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.64.3"},"crm":{"group_id":null},"content":{"id":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561","title":"Editorial: ALDOT should act now to save lives","type":"article","published_time":"2022-11-04T19:50:00Z","tags":[],"authors":[],"taxnonomies":{"blox_sections":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/section","items":[]},"blox_flags":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/flag","items":["featured"]}},"metrics":{"image_count":1,"video_count":0,"audio_count":0,"word_count":855},"byline":"By the editorial staff of The Chanticleer"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"ample","style":"default","path":"\/","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"the editorial staff of The Chanticleer","start_hour":"14","id":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561","app":"editorial","ga_page":"\/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":244},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-179442457-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.7b5fd2a1aa906214ae39b25cd6ec9283.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.ef1ae2cf9d9803199a19b009dc464018.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = 'e7fc502e-5c79-11ed-a034-eb9a7b5a0561';

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.a023713b7eff47127899286dc36e1970.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.fc1a4213adeec354910108f84bf0e732.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.d45f12d51e6b121b88d52db2e387136f.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/jsuchanticleer.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ function evvntDiscoveryInit_2612694() {
        evvnt_require("evvnt/discovery_plugin").init({
            publisher_id: "jsuchanticleer.com",
            discovery: {
                element: "#evvnt-calendar-2612694",
                detail_page_enabled: true,
                widget: true,
                virtual: false,
                map: false,
                category_id: null, 
                orientation: "portrait",
                number: 3,
            },
            submission: {
                partner_name: "The Chanticleer",
                text: "Promote your event",
            }
        });
    } /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"content_text":"Sign up for our weekly newsletters to stay in the loop","display_again":"168","display_timer":"5","display_triggers":"visitor_enter","enable_email":"1","headline_size":"medium","headline_text":"Never miss a story","overlay_action":"centered","require_user_account":"","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shape":"rounded_rectangle","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","image_display":"medium","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","headline_text_color":"dark","headline_shadow":"disabled","content_text_color":"dark","content_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","hide_audience":"","dmp_provider":"inherit","block_id":"2631168"}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"content_text":"Sign up for our weekly newsletters to stay in the loop","display_again":"168","display_timer":"5","display_triggers":"visitor_enter","enable_email":"1","headline_size":"medium","headline_text":"Never miss a story","overlay_action":"centered","require_user_account":"","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shape":"rounded_rectangle","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","image_display":"medium","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","headline_text_color":"dark","headline_shadow":"disabled","content_text_color":"dark","content_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","hide_audience":"","dmp_provider":"inherit","block_id":"2631168"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        if (window.localStorage) {
            var sID = window.localStorage.getItem('_us_master_id');
            if (sID) {
                googletag.pubads().setPublisherProvidedId(sID);
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Editorial: ALDOT should act now to save lives |  | jsuchanticleer.com</title>
            
    <style>body { background-color: #ffffff; color: #222222; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1366px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #ED1E24; } .fixed-nav #main-navigation { background-color: #ED1E24 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #efefef; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #fff; } .navbar-toggle .icon-bar { background-color: #fff !important; } .navbar-toggle .sr-only-show { color: #fff !important; } #site-top-nav .list-inline>li>a { color: #222222; } .asset .asset-body p, .asset #asset-content p { color: #222222; }@media (min-width: 1200px) { .container { width: 100%; } } @media (min-width: 1396px) { .container.has-wallpaper, .has-wallpaper .container, .container { width: 1366px; } } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #fff; } }#site-copyright a, #site-footer a { color: #000000; }.search-redesign .top-breakout > .row { max-width: 1366px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #ED1E24; }#site-header-container{ border-bottom: 3px solid #ED1E24; }#site-footer-container{ border-top: 3px solid #ED1E24; } .tnt-bg-accent { background-color: #ED1E24; } a .tnt-caret-down { color: #ED1E24; } .block-title .block-title-inner { border-color: #ED1E24; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #ED1E24; } .form-control:focus { border-bottom-color: #ED1E24; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.jsuchanticleer.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Editorial: ALDOT should act now to save lives |  | jsuchanticleer.com" href="http://www.jsuchanticleer.com/search/?f=rss&amp;t=article&amp;c=&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a7c71fa5a63ad1158170fb2c085be042.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-ample blox-asset uuid-e7fc502e-5c79-11ed-a034-eb9a7b5a0561 type-article infinity-disabled" data-path="/">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.jsuchanticleer.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.64.3&amp;townnews.content.id=e7fc502e-5c79-11ed-a034-eb9a7b5a0561&amp;townnews.content.title=Editorial%3A+ALDOT+should+act+now+to+save+lives&amp;townnews.content.type=article&amp;townnews.content.published_time=2022-11-04T19%3A50%3A00Z&amp;townnews.content.taxnonomies.blox_sections.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fsection&amp;townnews.content.taxnonomies.blox_flags.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fflag&amp;townnews.content.taxnonomies.blox_flags.items.0=featured&amp;townnews.content.metrics.image_count=1&amp;townnews.content.metrics.video_count=0&amp;townnews.content.metrics.audio_count=0&amp;townnews.content.metrics.word_count=855&amp;townnews.content.byline=By+the+editorial+staff+of+The+Chanticleer&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=ample&amp;tncms.page.style=default&amp;tncms.page.path=%2F&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=the+editorial+staff+of+The+Chanticleer&amp;tncms.asset.start_hour=14&amp;tncms.asset.id=e7fc502e-5c79-11ed-a034-eb9a7b5a0561&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=244&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-179442457-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.jsuchanticleer.com/tncms/admin/editorial-asset/?edit=e7fc502e-5c79-11ed-a034-eb9a7b5a0561"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-2612802" class="tncms-block in-drawer hamb-logo"><div id="site-logo-2612802" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=200%2C200" 
            srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png?resize=400%2C400 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/5239f000-0f6c-11ed-8535-ef55214760b9.png 540w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="512"
            height="512"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-2612799" class="tncms-block text-center padding-top"><div class="follow-links-2612799 follow-links default">
    
    <section id="block-2612799" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://Facebook.com/ChanticleerJSU" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/chanticleerjsu/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/jsu-chanticleer" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-xs btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="https://www.instagram.com/chanticleerjsu" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.jsuchanticleer.com",
  "sameAs" : ["http://Facebook.com/ChanticleerJSU","http://twitter.com/chanticleerjsu/","https://www.linkedin.com/company/jsu-chanticleer","https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ","https://www.instagram.com/chanticleerjsu"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-2612793" class="tncms-block hidden-md hidden-lg"><section id="block-2612793" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-2612793" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-2612793" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-2612793" class="site-search-form input-group default normal ">
        <label for="site-search-2612793-term" class="sr-only">Site search</label>
        <input id="site-search-2612793-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2612793-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-2612793" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div><div id="tncms-block-2612796" class="tncms-block hidden-lg hidden-md"><div id="user-controls-2612796" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.jsuchanticleer.com/users/signup/?referer_url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.jsuchanticleer.com/users/login/?referer_url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.jsuchanticleer.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-2612796').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.jsuchanticleer.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.jsuchanticleer.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.jsuchanticleer.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-2612796').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.jsuchanticleer.com/users/logout/" id="user-logout-form-2612796"><input type="hidden" name="referer_url" value="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/advertise.html"  class="nav-link tnt-section-advertise">Advertise</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/terms.html"  class="nav-link tnt-section-terms-of-use">Terms of Use</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/privacy.html"  class="nav-link tnt-section-privacy-policy">Privacy Policy</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/"  class="nav-link tnt-section-submission-forms">Submission Forms</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/"  class="nav-link tnt-section-local-weather">Local Weather</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wljs919/"  class="nav-link tnt-section-wljs-919-fm">WLJS 91.9 FM</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/campus/"  class="nav-link tnt-section-campus-news">Campus News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/community/"  class="nav-link tnt-section-community-news">Community News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/football/"  class="nav-link tnt-section-gamecocks-football">Gamecocks Football</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/basketball/"  class="nav-link tnt-section-gamecocks-basketball">Gamecocks Basketball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/baseballsoftball/"  class="nav-link tnt-section-gamecocks-baseball-softball">Gamecocks Baseball & Softball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/track/"  class="nav-link tnt-section-gamecocks-cross-country-track-field">Gamecocks Cross Country & Track & Field</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/golf/"  class="nav-link tnt-section-gamecocks-golf">Gamecocks Golf</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/rifle/"  class="nav-link tnt-section-gamecocks-rifle">Gamecocks Rifle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/soccer/"  class="nav-link tnt-section-gamecocks-soccer">Gamecocks Soccer</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/tennis/"  class="nav-link tnt-section-gamecocks-tennis">Gamecocks Tennis</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/volleyball/"  class="nav-link tnt-section-gamecocks-volleyball-beach-volleyball">Gamecocks Volleyball & Beach Volleyball</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/features/"  class="nav-link tnt-section-features ">Features</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/arts_entertainment/"  class="nav-link tnt-section-campus-arts">Campus Arts</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/columns/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guests/"  class="nav-link tnt-section-guest-columns">Guest Columns</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="/site/contact.html"  tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-wljs-919-fm"  href="/wljs919/"  tabindex="0" >
                    <span class="nav-label ">WLJS 91.9 FM</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-2612781" class="tncms-block header-weather"><div id="weather-2612781" class="weather-current size-medium pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/weather/?weather_zip=36265" class="dropdown-toggle"  aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">63&deg;</span>
                    
                        <span class="cond">Clear </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-2612790" class="tncms-block"><div id="site-logo-2612790" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=200%2C55" 
            srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=150%2C41 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=200%2C55 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=225%2C61 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=300%2C82 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=400%2C109 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png?resize=540%2C148 540w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/038d5eb0-0f49-11ed-8535-b3a317b4028f.png 640w"
            sizes="(min-width: 1396px) 683px, calc(50vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="593"
            height="162"
            alt="site-logo"
            ></a>
        </div></div></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-2612787" class="tncms-block header-social"><div class="follow-links-2612787 follow-links pull-right">
    
    <section id="block-2612787" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://Facebook.com/ChanticleerJSU" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/chanticleerjsu/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/jsu-chanticleer" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-md btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="https://www.instagram.com/chanticleerjsu" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.jsuchanticleer.com",
  "sameAs" : ["http://Facebook.com/ChanticleerJSU","http://twitter.com/chanticleerjsu/","https://www.linkedin.com/company/jsu-chanticleer","https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ","https://www.instagram.com/chanticleerjsu"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-2612772" class="tncms-block"><div id="site-logo-2612772" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=200%2C55" 
            srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=150%2C41 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=200%2C55 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=225%2C61 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=300%2C82 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=400%2C109 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png?resize=540%2C148 540w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/d04f7088-0f6b-11ed-8535-1b775c7e77be.png 640w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="593"
            height="162"
            alt="site-logo"
            ></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                    <span class="fas tnt-search"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-2612775" class="tncms-block"><ul id="site-search-2612775-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-2612775" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-2612775" class="site-search-form input-group pull-right normal ">
        <label for="site-search-2612775-term" class="sr-only">Site search</label>
        <input id="site-search-2612775-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2612775-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-2612775" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div><div id="tncms-block-2612778" class="tncms-block"><div id="user-controls-2612778" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                        <span class="sr-only">Open user controls</span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.jsuchanticleer.com/users/login/?referer_url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://www.jsuchanticleer.com/users/signup/?referer_url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.jsuchanticleer.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.jsuchanticleer.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.jsuchanticleer.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-2612778').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.jsuchanticleer.com/users/logout/" id="user-logout-form-2612778"><input type="hidden" name="referer_url" value="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown" aria-expanded="false">
                <a class="nav-link   nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="/site/contact.html"  tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="/site/advertise.html"  tabindex="0" >
                    <span class="nav-label ">Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-terms-of-use"  href="/site/terms.html"  tabindex="0" >
                    <span class="nav-label ">Terms of Use</span>
                </a></li><li>
                <a class="nav-link    tnt-section-privacy-policy"  href="/site/privacy.html"  tabindex="0" >
                    <span class="nav-label ">Privacy Policy</span>
                </a></li><li>
                <a class="nav-link    tnt-section-submission-forms"  href="/site/forms/"  tabindex="0" >
                    <span class="nav-label ">Submission Forms</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-weather"  href="/weather/"  tabindex="0" >
                    <span class="nav-label ">Local Weather</span>
                </a></li><li>
                <a class="nav-link    tnt-section-wljs-919-fm"  href="/wljs919/"  tabindex="0" >
                    <span class="nav-label ">WLJS 91.9 FM</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-campus-news"  href="/news/campus/"  tabindex="0" >
                    <span class="nav-label ">Campus News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-community-news"  href="/news/community/"  tabindex="0" >
                    <span class="nav-label ">Community News</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-gamecocks-football"  href="/sports/football/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Football</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-basketball"  href="/sports/basketball/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Basketball</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-baseball-softball"  href="/sports/baseballsoftball/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Baseball & Softball</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-cross-country-track-field"  href="/sports/track/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Cross Country & Track & Field</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-golf"  href="/sports/golf/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Golf</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-rifle"  href="/sports/rifle/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Rifle</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-soccer"  href="/sports/soccer/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Soccer</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-tennis"  href="/sports/tennis/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Tennis</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gamecocks-volleyball-beach-volleyball"  href="/sports/volleyball/"  tabindex="0" >
                    <span class="nav-label ">Gamecocks Volleyball & Beach Volleyball</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/features/"  tabindex="0" >
                    <span class="nav-label ">Features</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-calendar"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Calendar</span>
                </a></li><li>
                <a class="nav-link    tnt-section-campus-arts"  href="/features/arts_entertainment/"  tabindex="0" >
                    <span class="nav-label ">Campus Arts</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/"  tabindex="0" >
                    <span class="nav-label ">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link    tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0" >
                    <span class="nav-label ">Editorials</span>
                </a></li><li>
                <a class="nav-link    tnt-section-columnists"  href="/opinion/columns/"  tabindex="0" >
                    <span class="nav-label ">Columnists</span>
                </a></li><li>
                <a class="nav-link    tnt-section-guest-columns"  href="/opinion/guests/"  tabindex="0" >
                    <span class="nav-label ">Guest Columns</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #ED1E24">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><div id="modal-image-ff9efe38-5c7a-11ed-beed-53eec1a87b8d" class="modal fullscreen in modal-image image-default modal-ff9efe38-5c7a-11ed-beed-53eec1a87b8d" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=400%2C225"
                        srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=990%2C557 990w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1035%2C582 1035w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1333%2C750 1333w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1476%2C830 1476w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1920%2C1080 2008w"
                        sizes="100vw"
                        
                        width="1920"
                        height="1080"
                        alt="Merrill Hall and Brewer Hall"
                        class="img-responsive true-size blur" />
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-ff9efe38-5c7a-11ed-beed-53eec1a87b8d" data-target=".caption-inner-modal-image-ff9efe38-5c7a-11ed-beed-53eec1a87b8d">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-ff9efe38-5c7a-11ed-beed-53eec1a87b8d collapse in"><div class="caption-text"><p>Photo Courtesy of Jacksonville State University</p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Fmerrill-hall-and-brewer-hall%2Fimage_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Merrill%20Hall%20and%20Brewer%20Hall&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Fmerrill-hall-and-brewer-hall%2Fimage_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/ff9efe38-5c7a-11ed-beed-53eec1a87b8d" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Merrill%20Hall%20and%20Brewer%20Hall&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Fmerrill-hall-and-brewer-hall%2Fimage_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"ff9efe38-5c7a-11ed-beed-53eec1a87b8d"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.jsuchanticleer.com/merrill-hall-and-brewer-hall/image_ff9efe38-5c7a-11ed-beed-53eec1a87b8d.html', '[data-copy-inline-ff9efe38-5c7a-11ed-beed-53eec1a87b8d]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Image link copied to clipboard"
                    data-copy-inline-ff9efe38-5c7a-11ed-beed-53eec1a87b8d
                >
                    <span class="tnt-stack" title="Copy image link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-ff9efe38-5c7a-11ed-beed-53eec1a87b8d-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="ff9efe38-5c7a-11ed-beed-53eec1a87b8d" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="ff9efe38-5c7a-11ed-beed-53eec1a87b8d" class="save-list-ff9efe38-5c7a-11ed-beed-53eec1a87b8d-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="ff9efe38-5c7a-11ed-beed-53eec1a87b8d" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-ff9efe38-5c7a-11ed-beed-53eec1a87b8d img { max-height: 1080px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="asset article-default"  data-url="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Wednesday’s occurrence involving JSU student Leah Tarvin being struck by a motor vehicle has pained the Jacksonville community. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?crop=1920%2C1008%2C0%2C35&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="jsuchanticleer.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" />
    <style>
                .asset-paging .direction {
                    color: #ED1E24;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.jsuchanticleer.com\/tncms\/search\/mlt\/?origin=e7fc502e-5c79-11ed-a034-eb9a7b5a0561&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="asset-paging">
                <div id="paging-prev-e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="paging-link prev offset"></div>
                <div id="paging-next-e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
    <span>Editorial: ALDOT should act now to save lives</span>
</h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By the editorial staff of The Chanticleer</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-11-04T14:50:00-05:00" class="tnt-date asset-date text-muted">
            Nov 4, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-11-04T14:50:00-05:00" class="tnt-date asset-date text-muted">5 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-11-04T14:50:00-05:00">
    <meta itemprop="datePublished" content="2022-11-04T14:50:00-05:00">
    <meta itemprop="dateModified" content="2022-11-04T14:50:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-blur"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-ff9efe38-5c7a-11ed-beed-53eec1a87b8d" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-ff9efe38-5c7a-11ed-beed-53eec1a87b8d" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1920">
            <meta itemprop="height" content="1080">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1396%2C785">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1396%2C785"><img
                        src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=400%2C225"
                        srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=990%2C557 990w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1035%2C582 1035w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1333%2C750 1333w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1476%2C830 1476w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=1920%2C1080 2008w"
                        sizes="(min-width: 1396px) 881px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="1920"
                        height="1080"
                        alt="Merrill Hall and Brewer Hall"
                        class="img-responsive full tnt-restrict-img-ff9efe38-5c7a-11ed-beed-53eec1a87b8d blur" />
            </div><style>
                .tnt-restrict-img-ff9efe38-5c7a-11ed-beed-53eec1a87b8d {
                    max-width: 1920px;
                }
            </style>
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/assets/v3/editorial/f/f9/ff9efe38-5c7a-11ed-beed-53eec1a87b8d/63656f19912bf.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Photo Courtesy of Jacksonville State University</p>
                                </span>
                            
                        
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" data-smart-adunit="//jsuchanticleer.com//">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html', '[data-copy-stacked-e7fc502e-5c79-11ed-a034-eb9a7b5a0561]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="right"
                    data-content="Article link copied to clipboard"
                    data-copy-stacked-e7fc502e-5c79-11ed-a034-eb9a7b5a0561
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html', '[data-copy-inline-top-e7fc502e-5c79-11ed-a034-eb9a7b5a0561]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-top-e7fc502e-5c79-11ed-a034-eb9a7b5a0561
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p dir="ltr"><span><a href="https://www.jsuchanticleer.com/news/jsu-student-struck-in-crosswalk-by-car-on-campus/article_70a83bac-5b14-11ed-8d07-376804812dd1.html" target="_blank">Wednesday’s occurrence</a> involving JSU student Leah Tarvin being struck by a motor vehicle has pained the Jacksonville community.</span></p><p dir="ltr"><span>As a staff, our thoughts and prayers go out to Tarvin and her family.</span></p><p dir="ltr"><span>A report shared Friday afternoon from WVTM 13’s Rick Karle says that Leah’s uncle, Paul Barbee, said the family is “praying for a miracle.”</span></p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p dir="ltr"><span>With the lack of safety features causing pedestrian accidents that have endangered students, staff and community members, the Alabama Department of Transportation needs to invest in infrastructure that can help prevent accidents from occuring. </span></p><p dir="ltr"><span>Wednesday’s occurrence involving Tarvin adds to a list that is far too long of pedestrians being struck by motor vehicles, with one of these taking the life of a JSU student.</span></p><p dir="ltr"><span>On Feb. 5, 2018 at around 7:30 p.m., 23-year old student Justin Wayne Tinker was struck by a motor vehicle crossing Alabama 204 on the Chief Ladiga Trail. Less than an hour and a half later, he was pronounced dead at Regional Medical Center in Anniston.</span></p><p dir="ltr"><span>Less than seven months later, on Sept. 6, 2018, JSU student Jace Sproull was struck by a motor vehicle attempting to cross Alabama 204 near the International House. Sproull sustained a cut to the head and was taken to Gadsden Regional Medical Center.</span></p><p dir="ltr"><span>Along with these incidents, other occurrences from just this year saw those in the Jacksonville community urging lawmakers to further bolster the safety of pedestrians.</span></p><p dir="ltr"><span>Just last semester, a pair of incidents within less than two weeks of each other urged students to “take precaution,” when walking and driving on or around campus.</span></p><p dir="ltr"><span>The first incident reported was in the afternoon of Jan. 20 at the University Recreation Center when two staff members were struck by a student motorist at the crosswalk on Pelham Road at Beck Circle. </span></p><p dir="ltr"><span>One victim was hospitalized as a result of the incident.</span></p><p dir="ltr"><span>The second occurred in the evening of Feb. 1 at the crosswalk on Pelham Road at University Circle towards the library, when a JSU student was struck by a motorist that was not affiliated with JSU. </span></p><p dir="ltr"><span>The driver fled the scene and the student refused medical treatment when officers arrived.</span></p><p dir="ltr"><span>University leaders have explored options that could keep this list of accidents involving pedestrians being struck by vehicles from growing.</span></p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p dir="ltr"><span>However, many of these plans were shut down from the beginning, with the few plans that had the state involved being shut down.</span></p><p dir="ltr"><span>In 2010, plans to build a walkway over Alabama 21 were put on hold.</span></p><p dir="ltr"><span>According to a report from the Anniston Star on Jan. 3, 2010, the overpass was expected to be near the lower end of Trustee Street and span across the road.</span></p><p dir="ltr"><span>The Anniston Star said in the article that the plans were put on hold because of an economic downturn, and that “members of Congress have been clear that projects won’t be funded until the economy picks back up and revenues start building again.”</span></p><p dir="ltr"><span>Over 12 years later, there have not been any reports of the state revisiting the plan.</span></p><p dir="ltr"><span>Wednesday’s events and others mentioned have made many call on Jacksonville State and the city to explore a solution to the problem with new infrastructure, including an overpass, adding pedestrian signs or adding additional lighting to make the crosswalk more visible.</span></p><p dir="ltr"><span>However, a statement issued by President Killingsworth on Thursday afternoon reiterated that neither Jacksonville State or the City of Jacksonville are able to build anything directly without discretion from the Alabama Department of Transportation.</span></p><p dir="ltr"><span>“Since Highways 21 and 204 are state-controlled, it limits the university and city's ability to make improvements to keep our community safe,” Killingsworth said in the release. “Representatives from the university and the City of Jacksonville have met with the Alabama Department of Transportation as recently as March to request their assistance, but were told the crash data does not warrant any additional precautions. We have already reached out, once again, for assistance.”</span></p><p dir="ltr"><span>In addition to Killingworth’s statement, ALDOT Media and Community Relations Bureau Chief Tony Harris released a statement to ABC 33/40, saying that the crosswalks were upgraded a few years ago.</span></p><p dir="ltr"><span>“The crosswalks are marked with advanced warning signs and other devices to warn drivers to yield for pedestrians, which is required by state law,” Harris said in the release. “ALDOT will continue working with University officials to explore other possible safety measures.”</span></p><p dir="ltr"><span>Despite what is required by state law in place, Tarvin and many others have fallen victim to the fact that the bare minimum is in place on this crosswalk.</span></p><p dir="ltr"><span>While Killingworth and leaders at Jacksonville State await a response from the state, it seems that the ball still lies in the court of the Alabama Department of Transportation.</span></p><p dir="ltr"><span>This incident and many others could have been prevented if the Alabama Department of Transportation would not only ensure that what is required by state law is in place, but put the safety of students, staff and community members first.</span></p><p dir="ltr"><span>As a staff, we urge the Alabama Department of Transportation to think about the safety of the students of Jacksonville State and invest in infrastructure that will help prevent incidents involving pedestrians and motor vehicles.</span></p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&url=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.jsuchanticleer.com/tncms/asset/editorial/e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Chanticleer%5D%20Editorial%3A%20ALDOT%20should%20act%20now%20to%20save%20lives&body=https%3A%2F%2Fwww.jsuchanticleer.com%2Feditorial-aldot-should-act-now-to-save-lives%2Farticle_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e7fc502e-5c79-11ed-a034-eb9a7b5a0561"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.jsuchanticleer.com/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html', '[data-copy-inline-e7fc502e-5c79-11ed-a034-eb9a7b5a0561]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-e7fc502e-5c79-11ed-a034-eb9a7b5a0561
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" class="save-list-e7fc502e-5c79-11ed-a034-eb9a7b5a0561-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e7fc502e-5c79-11ed-a034-eb9a7b5a0561" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-2612751" class="tncms-block"><section id="block-2612751" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2612751 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/jsu-student-struck-in-crosswalk-by-car-on-campus/article_70a83bac-5b14-11ed-8d07-376804812dd1.html" class="tnt-asset-link" aria-label="JSU student struck in crosswalk by car on campus">
        

        
            JSU student struck in crosswalk by car on campus</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/new-building-projects-mean-more-parking-here-s-the-university-s-plan/article_5173c9f0-50aa-11ed-be4e-1fb9f710ba7f.html" class="tnt-asset-link" aria-label="New building projects mean more parking, here’s the university’s plan">
        

        
            New building projects mean more parking, here’s the university’s plan</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/sports/football/jsu-decimates-austin-peay-on-the-road-remains-undefeated-in-asun-play/article_8a41bc82-57e5-11ed-942b-9fa308fff7c9.html" class="tnt-asset-link" aria-label="JSU decimates Austin Peay on the road, remains undefeated in ASUN play">
        

        
            JSU decimates Austin Peay on the road, remains undefeated in ASUN play</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/editorial-aldot-should-act-now-to-save-lives/article_e7fc502e-5c79-11ed-a034-eb9a7b5a0561.html" class="tnt-asset-link" aria-label="Editorial: ALDOT should act now to save lives">
        

        
            Editorial: ALDOT should act now to save lives</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/student-workers-minimum-wage-raised-at-trustees-meeting/article_3ecb62a8-53b2-11ed-ba93-3bc217b07fd4.html" class="tnt-asset-link" aria-label="Student workers’ minimum wage raised at trustees meeting">
        

        
            Student workers’ minimum wage raised at trustees meeting</a></h5>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-2616819" class="tncms-block title-no-margin"><section id="block-2616819" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2616819 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="https://www.facebook.com/ChanticleerJSU">
                
                Follow us on Facebook
                
                    </a>
                
            </h3>
        </div>
    </div></div></section></div><div id="tncms-block-2616822" class="tncms-block"><script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=1550124928647000";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><div class="fb-page" data-href="https://www.facebook.com/ChanticleerJSU" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="true" style="margin-left:10px" data-height="350"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ChanticleerJSU"><a href="https://www.facebook.com/ChanticleerJSU">ChanticleerJSU</a></blockquote></div></div>
<div class="padding-top padding-bottom"></div></div><div id="tncms-block-2616813" class="tncms-block title-no-margin"><section id="block-2616813" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2616813 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="https://twitter.com/ChanticleerJSU">
                
                Follow us on Twitter
                
                    </a>
                
            </h3>
        </div>
    </div></div></section></div><div id="tncms-block-2616816" class="tncms-block"><a class="twitter-timeline" href="https://twitter.com/ChanticleerJSU" data-height="450">Tweets by ChanticleerJSU</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script><div class="padding-top padding-bottom"></div></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"><div id="tncms-block-2612694" class="tncms-block"><section id="block-2612694" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2612694 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/local-events">
                
                Local Events
                
                    </a>
                
            </h3>
        </div>
    </div></div><div id="evvnt-calendar-2612694"></div>
<script async defer src="//discovery.evvnt.com/prd/evvnt_discovery_plugin-latest.min.js" onload="evvntDiscoveryInit_2612694();"></script></section></div></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-2612760" class="tncms-block eedition-rail"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-2631168" class="tncms-block"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-2631168" class="block emphasis-h3   " ><div class="promo-design card-rounded-rectangle"><div class="card-bg-color rounded_rectangle"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button><div class="card-panel panel"><div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline medium dark ">
                            Never miss a story
                        </div>
                    
                    
                        <p class="text dark ">
                            Sign up for our weekly newsletters to stay in the loop
                        </p>
                    <div class="card email-signup">
                                <div class="alert alert-success" role="alert" style="display:none;">
                                    <p>
                                        <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
                                    </p>
                                </div>
                                <div class="alert alert-danger" role="alert" style="display:none;">
                                    <p>
                                        <strong>Error!</strong> There was an error processing your request.
                                    </p>
                                </div>
                                <div class="mailinglist-container dark  ">
                                        <form
                                            id="mailinglist-form-2631168"
                                            class="mailinglist-form form-validate"
                                            action="/tncms/mailinglist/signup/"
                                            method="post">
                                            <input type="hidden" name="submit" value="1">
                                            <div class="form-group mailing-lists ">
                                                
                                                    <div class="mailinglist-item priority-50 checkbox">
                                                        <label>
                                                            <input class="mailinglist-id-2631168" type="checkbox" name="list_id[]" value="fae70374-0dbd-11ed-bb03-b78ceda21e9c" data-name="Weekly Headlines" >
                                                            <h4 class="mailinglist-title">Weekly Headlines</h4>
                                                            
                                                                
                                                                    <p>Have the latest local news delivered every week so you don't miss out on updates and get notified of breaking news as it happens.</p>
                                                                
                                                            
                                                        </label>
                                                    </div>
                                                
                                                    <div class="mailinglist-item priority-40 checkbox">
                                                        <label>
                                                            <input class="mailinglist-id-2631168" type="checkbox" name="list_id[]" value="301b6378-0dbe-11ed-bb03-633f0d5c826d" data-name="Chanticleer Sports" >
                                                            <h4 class="mailinglist-title">Chanticleer Sports</h4>
                                                            
                                                                
                                                                    <p><span style="color: #000000;">Get the latest headlines on sports!</span></p>
                                                                
                                                            
                                                        </label>
                                                    </div>
                                                
                                                    <div class="mailinglist-item priority-0 checkbox">
                                                        <label>
                                                            <input class="mailinglist-id-2631168" type="checkbox" name="list_id[]" value="5ccbaca2-0dbe-11ed-bb03-030ffd04452e" data-name="Weekly Most Read" >
                                                            <h4 class="mailinglist-title">Weekly Most Read</h4>
                                                            
                                                                
                                                                    <p><span style="color: #000000;">Trending stories from the week.</span></p>
                                                                
                                                            
                                                        </label>
                                                    </div>
                                                
                                                <label class="warning-list hide has-error text-danger" for="list_id[]">You must select at least one email list.</label>
                                            </div>
                                            <div class="form-group email-address">
                                                <div class="input-group">
                                                    <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                                                    <input id="email-2631168" class="form-control email" name="email" type="email" placeholder="Enter email address">
                                                </div>
                                                <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                                            </div>
                                            <div class="row">
                                                <div class="mailinglist-btn-container col-sm-6">
                                                    <button class="mailinglist-save btn btn-block btn-default">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                                                </div>
                                                
                                                    <div class="mailinglist-btn-container col-sm-6">
                                                        <a class="btn btn-default btn-block manage" href="https://www.jsuchanticleer.com/users/admin/mailinglist/">Manage your lists</a>
                                                    </div>
                                                
                                            </div>
                                        </form>
                                    </div>
                                
                            </div></div>
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-2612703" class="tncms-block"><section id="block-2612703" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2612703 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-news"  href="/news/"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-features"  href="/features/"  tabindex="0" >
                    <span class="nav-label ">Features</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion/"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label ">Multimedia</span>
                </a></li><li>
                <a class="nav-link    tnt-section-online-features"  href="/online_features/"  tabindex="0" >
                    <span class="nav-label ">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-2612700" class="tncms-block"><section id="block-2612700" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2612700 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-submission-forms"  href="/site/forms/"  tabindex="0" >
                    <span class="nav-label ">Submission Forms</span>
                </a></li><li>
                <a class="nav-link    tnt-section-calendar"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Calendar</span>
                </a></li><li>
                <a class="nav-link    tnt-section-email-alerts"  href="/newsletter/"  tabindex="0" >
                    <span class="nav-label ">Email Alerts</span>
                </a></li><li>
                <a class="nav-link    tnt-section-search"  href="/search/"  tabindex="0" >
                    <span class="nav-label ">Search</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather/"  tabindex="0" >
                    <span class="nav-label ">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-2613225" class="tncms-block"><section id="block-2613225" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2613225 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Us
                
            </h4>
        </div>
    </div></div><address>
    <strong>JSUchanticleer.com</strong><br>
    700 Pelham Road N<br>
    Jacksonville, AL 36265
    <br>
    
        <strong>Phone:</strong> 256-782-5701<br>
        <strong>Email:</strong> <a href="mailto:info@jsuchanticleer.com">info@jsuchanticleer.com</a><br>
    
</address></section></div><div id="tncms-block-2613222" class="tncms-block footer-logo"><div id="site-logo-2613222" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=200%2C200" 
            srcset="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png?resize=400%2C400 400w, https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/content/tncms/custom/image/f29c1200-0f5b-11ed-8535-678d7f868207.png 540w"
            sizes="(min-width: 1396px) 455px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="512"
            height="512"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-2613219" class="tncms-block footer-social"><div class="follow-links-2613219 follow-links default">
    
    <section id="block-2613219" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://Facebook.com/ChanticleerJSU" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/chanticleerjsu/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/jsu-chanticleer" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-xs btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="https://www.instagram.com/chanticleerjsu" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.jsuchanticleer.com",
  "sameAs" : ["http://Facebook.com/ChanticleerJSU","http://twitter.com/chanticleerjsu/","https://www.linkedin.com/company/jsu-chanticleer","https://www.youtube.com/channel/UCZD1I6b4w3mZuM1UbL2jjGQ","https://www.instagram.com/chanticleerjsu"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-2612706" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-2612706"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">The Chanticleer</a>, 700 Pelham Road N Jacksonville, AL</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("e7fc502e-5c79-11ed-a034-eb9a7b5a0561")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': [""],
            'tncms.asset.flags': ["featured"],
            'tncms.asset.keywords': [""]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-2612793'),
            query_input = d.getElementById('site-search-2612793-term'),
            search_dropdown = d.getElementById('site-search-2612793-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-2612793 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-2612775'),
            query_input = d.getElementById('site-search-2612775-term'),
            search_dropdown = d.getElementById('site-search-2612775-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-2612775 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.e7774288ce226361ffdb45b8dd559781.js"></script>
<script>/*<![CDATA[*/ 
                    /* Copy url to clipboard */
                    function copyLink(url, copyTarget) {
                        /* Populate clipboard */
                        navigator.clipboard.writeText(url);
                        
                        /* Bootstrap popover */
                         $(copyTarget).popover().popover("show").prop("disabled", true);
                        
                        /* Hide popover after timeout */
                        setTimeout(
                            function() {
                               $(copyTarget).popover("hide").popover("destroy").prop("disabled", false);
                            }, 2000);
                    } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/jsuchanticleer.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script></body>
</html>